We are continuing to work on a fix for this issue.
Posted Oct 21, 2025 - 02:04 EDT
Update
We’ve restored Lending Services. The Selling Service continues to function but is experiencing slower performance. Our teams are actively working with the cloud provider to bring it back to full capacity.
Posted Oct 21, 2025 - 01:14 EDT
Update
We’ve restored Lending Services. The Selling Service continues to function but is experiencing slower performance. Our teams are actively working with the cloud provider to bring it back to full capacity.
Posted Oct 20, 2025 - 23:50 EDT
Update
We’ve restored Lending Services. The Selling Service continues to function but is experiencing slower performance. Our teams are actively working with the cloud provider to bring it back to full capacity.
Posted Oct 20, 2025 - 22:48 EDT
Update
We’ve restored Lending Services. The Selling Service continues to function but is experiencing slower performance. Our teams are actively working with the cloud provider to bring it back to full capacity.
Posted Oct 20, 2025 - 21:47 EDT
Update
We’ve restored Lending Services. The Selling Service continues to function but is experiencing slower performance. Our teams are actively working with the cloud provider to bring it back to full capacity.
Posted Oct 20, 2025 - 20:44 EDT
Update
We’ve restored Lending Services. The Selling Service continues to function but is experiencing slower performance. Our teams are actively working with the cloud provider to bring it back to full capacity.
Posted Oct 20, 2025 - 19:41 EDT
Update
We’ve restored Lending Services. The Selling Service continues to function but is experiencing slower performance. Our teams are actively working with the cloud provider to bring it back to full capacity.
Posted Oct 20, 2025 - 18:21 EDT
Update
Lending Services are back online. The Selling Service is operational but currently underperforming. We're coordinating with our cloud provider to restore optimal performance as soon as possible.
Posted Oct 20, 2025 - 17:31 EDT
Update
We are continuing to work on a fix for this issue.
Posted Oct 20, 2025 - 16:32 EDT
Update
All Lending Services have been restored The Selling Service remains operational but is currently experiencing degraded performance. Our teams are actively collaborating with our cloud provider to restore full functionality as soon as possible.
Posted Oct 20, 2025 - 16:30 EDT
Update
All Lending Services have been restored The Selling Service remains operational but is currently experiencing degraded performance. Our teams are actively collaborating with our cloud provider to restore full functionality as soon as possible.
Posted Oct 20, 2025 - 15:47 EDT
Update
All Lending Services have been restored The Selling Service remains operational but is currently experiencing degraded performance. Our teams are actively collaborating with our cloud provider to restore full functionality as soon as possible.
Posted Oct 20, 2025 - 15:30 EDT
Update
All Lending Services have been restored. The Selling Service is operational but currently experiencing degraded performance while we work with our cloud provider to fully resolve the issue.
Posted Oct 20, 2025 - 13:31 EDT
Update
All Lending Services have been restored. The Selling Service is operational but currently experiencing degraded performance while we work with our cloud provider to fully resolve the issue.
Posted Oct 20, 2025 - 13:07 EDT
Update
We are continuing to work on a fix for this issue.
Posted Oct 20, 2025 - 10:59 EDT
Update
Our team remains engaged in developing a fix for this issue
Posted Oct 20, 2025 - 09:58 EDT
Update
Our team remains engaged in developing a fix for this issue
Posted Oct 20, 2025 - 09:26 EDT
Update
We are continuing our efforts to resolve this issue
Posted Oct 20, 2025 - 08:45 EDT
Update
Our team is continuing to work on resolving this issue.
Posted Oct 20, 2025 - 08:16 EDT
Identified
Please note that some Cross River services have been impacted by a global outage at our third party cloud provider. Our team is working to ensure all services are fully on-line and we apologize if you experience any issues in the interim. We will provide an update in due course.
Posted Oct 20, 2025 - 07:51 EDT
Investigating
We are currently investigating this issue.
Posted Oct 20, 2025 - 07:05 EDT
Update
We are continuing to monitor for any further issues.
Posted Oct 20, 2025 - 06:36 EDT
Update
Please note that some Cross River services have been impacted by an outage with our third party cloud provider. We are currently monitoring and will provide an update in due course.
we apologize for any inconvenience this may cause.
Posted Oct 20, 2025 - 06:07 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Oct 20, 2025 - 05:35 EDT
Investigating
Our NOC team has identified a possible degradation of performance in Lending (Arix) API, due to a third-party outage. This is currently under investigation. Customers may experience some performance and availability issues.
Additional updates will be provided soon. For any questions you may have, please contact Lending support (lending.support@crossriver.com).